Buscar este blog

lunes, 5 de enero de 2009

mis problemas y xorg

Otro error
¿cómo aprender equivocandose?
¿cómo la regué esta vez?
descompuse mi servidor x y lo recupere en una tarde


bueno hace rato que inicié con mi manejo de la computadora,a y hace ya un año que en casa solo tengo GNU/Linux (ubuntu- Edubuntu 7.10) cómo sistema operativo.

En este tiempo he estado haciendo varias cosas como pueden leer en este mi Blog, y apoyándome en mi amigo Mil, algunas premisas están presentes siempre, pero a veces por comodidad no las tomo en cuenta... jejeje

premisas

  • Para aprender lo mejor es hacer.

  • Para aprender algo bien, lo mejor tratar de enseñarlo.

  • Si quieres hacer algo lo mejor es leer antes de hacer.

  • Para hacer sin dudas, hay que leer completo el manual.

  • Para hacer las cosas bien es conveniente leer bien.

  • Para resolver tus dudas, hay que leer.

  • Para preguntar dudas, hay que leer y usar las "etiqueta" (forma correcta) de las preguntas.

  • La primera respuesta seguramente será ya leíste el manual.

  • Para hacer pruebas, hay que leer primero.

  • Si está bien mejor no lo arregles...



Bueno,pues bien, me he topado con varios problemas con mi computadora debido a varios cambios que he hecho en mi computadora. si lo he resuelto y hasta hoy no he perdido mi información. Que ya es algo grande :)

En un principio tenía en mi Computadora Windows XP y cuando cambié a GNU/Linux perdí el Windows, pero a mí no me importó mucho,pero la verdad a mi esposa no le gustó nada. bueno como ella no estaba trabajando mucho en la computadora pues la usaba esporádicamente con muchísimos problemas derivados de la costumbre a las aplicaciones que usaba antes y a las que estaba acostumbrada.

Pero creo que el mayor disgusto por ese tiempo fue cuando eliminé la partición de sistema de Windows y la convertí en una partición más para guardar los videos y música de mis hijas. y entonces no podía entrar a mi equipo más que por medio de un LiveCD. y como no sabía suficiente de cómo configurar y/ó corregir la configuración del GRUB llegué a conocer sobre SuperGrubDisk en el cual en ese momento no tuve ningún problema en gastar un CD para recuperar mi menú de inicio, me encantó que solo tuviera que iniciar desde el CD y me recuperara el menú de inicio de ubuntu prácticamente solo con un para de enters.

Hay otras experiencias que platicar como que ya remastericé Puppy Linux para que integrara openoffice.org. que aunque pudieron presentar errores no siempre corregí todos por la premura de tiempo... (en particular en la remasterización de Puppy la arreglé para que por default use la opción de cargarse en ram en véz de buscar algún rastro en el discoduro, pero no quité los iconos para accesos al as unidades que tenía la PC donde remastericé, cosa que no me gusta porque influye en la presentación del escritorio)

La última es la de Hoy:
Historia Corta
Antes de leer más y quedar suficientemente empapado sobre el asunto para usar correctamente la tarjeta de aceleración de gráficos ejecuté en una terminal una comando que me llevó a perder el acceso al escritorio, y después de instalar el navegador lynx para terminal texto, y después de un rato pude recuperar la configuración del servidor x y reiniciar la máquina para que entrar de modo normal a mi escritorio y hacer este escrito.

Historia Larga

hace algún tiempo tuve que saber sobre que tarjetas tiene alguna computadora para instalar o configurar algún dispositivo o simplemente saber al respecto.

eso me llevó a conocer los comandos:
lspci - permite ver en pantalla los dispositivos conectados en los slots PCI
lsusb - permite ver en la pantalla los dispositivos conectados a los puertos USB
lshw - permite ver todos los dispositivos que tiene tu PC instalados. De este programas en partícular me pareció importantísimo (bueno me gustó mucho) es que te permite formatear la salida pas que integre etiquetas html, lo que visto en un navegador te permite ver una codificación de color que te permite saber que dispositivos funcionan adecuadamente y cuales podrían presentar problemas.

la forma que en que mando esta información al escritorio es:

sudo lshw -html > ~/Escritorio/hardware.html

Hoy quise tratar de ver la televisión en mi computadora ya que hace tiempo que tengo una tarjeta sintonizadora de tv AverMedia la cual ví en la terminal:
sudo lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:08.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
00:08.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)
Sin embargo no he podido ver TV en la PC, supongo que porque me falta
  1. buscar más información sobre el software y el hardware de manera pueda ver la TV
  2. Talvez instalar una Tarjeta aceleradora de video.
eso me llevó de nuevo a lainformación obtenida por lshw

He revisado esta información varias veces y siempre encuentro el problema con mi Tarjeta de video, que muestra la siguiente información.






















id: pci
description: PCI bridge
product: VT8237 PCI Bridge
vendor: VIA Technologies, Inc.
physical id: 1
bus info: pci@0000:00:01.0
version: 00
width: 32 bits
clock: 66MHz
capabilities: pci pm normal_decode bus_master cap_list
id: display
description: VGA compatible controller
product: UniChrome Pro IGP
vendor: VIA Technologies, Inc.
physical id: 0
bus info: pci@0000:01:00.0
version: 01
width: 32 bits
clock: 66MHz
capabilities: pm agp agp-3.0 vga_controller bus_master cap_list
configuration: latency = 32

mingnt = 2


Revisando en googlubuntu encontré una línea de respuestas sobre mi tarjeta de video y aún cuando no tenía problemas reales, no tengo aceleración 2D ó 3D, ni los muy bonitos efectos en mi escritorio.

Antes de leer más y quedar suficientemente empapado sobre el asunto ejecuté en una terminal
sudo dpkg-reconfigure -phigh xserver-xorg

Al ejecutarse dijo que había guardado un respaldo en alguna parte que no leí ni puse atención, y como me desesperé porque no "pasaba nada", reinicie el servidor X.


y quedó ciclado sin que pudiera entrar ni al Servidor X ó a la terminal de texto, por lo que tuve que reiniciar en modo de recuperación para tratar de configurar xorg y regresar a mi escritorio normal, pero no se pudo por el método automático de recuperación. para iniciar el servidor x use varias veces.

Al arreglar por medio de dpgk no encontró ningún problema y xorgconf no me permitía inicar el servidor X porque estaba incompleto el archivo ó simplemente la configuración automática no reconocía correctamente mi configuración.
startx
al iniciar el servidor x me parecían mensajes de error en la terminal 6 y me regresaba a la terminal 1 modo texto que es en la que estaba trabajando.

Necesitaba ayuda y como no sabía exactamente cómo hacerle y no tenía Mozilla Firefox para revisar el internet lo primero que tuve que hacer fue instalar un navegador que ya conocía y que trabaja en terminal de texto.

sudo apt-get install lynx

y usando 3 terminales pude revisar www.google.com.mx, www.googlubuntu.com, pero aún cuando google si me permitío encontrar algunas ligas relacionadas las dos o trés ligas que encontré no me dieron la solución que buscaba... también quiero comentar que googlubuntu no me sirvío de ayuda, ya que no mostraba respuestas, en Lynx los acentos realmente parece que dan lata, así que se tienes que escribir si ellos.. ;) se me prendío el foco para intentar algo más.

fué entonces, mientras estaba revisando estas ligas recordé otras instrucciónes que me fueron de ayuda:
whereis - permite localizar algún archivo dentro del sistema.
cp - copiar un archivo
rm - borrar un archivo o directorio

whereis xorg.conf
me llevó a localizar la dirección del la configuración que necesitaba, y como realmente no sé usar el comando cp mejor usé el editor de texto pico para revisar cual de los archivos tenía la configuración que funcionaba.

así que al final lo que hice fue en una teminal
sudo su

Convertir el usuario de la terminal actual a root

pico /etc/X11/xorg.conf.20090105164533

editar un archivo, en este caso el archivo del respaldo más antiguo que se hizo hoy al hechar a perder la configuración del Servidor X ctrl+oPara grabar los "cambios" (que en este caso no hubo) pero que necesitaba grabar en el archivo xorg.conf por lo que cambié el nombre borrando lo que sobra, después enter para aceptar el nuevo nombre manda el mensaje " Ya existe el archivo ¿SOBREESCRIBIR? " presioné s y salí de pico presionandoctrl+x . Según yo ya estaba reparado, así que probé desde otra terminal y en modo usuario para no cometer más burradas ( bueno errores)
startx
que me inicio una bonita pantalla gráfica con una x por puntero. me dije... "que yá esté... que ya esté..." crucé lo dedos mentalmente y reinicie mi computadora cerrando antes todas la terminales de texto y dejando hasta el final en la que está como root y desde ahí reinicie fácilmente presionando ctrl + alt + supr.

esperé el inicio normal y obtuve la conocida ventana de acceso en modo gráfico para iniciar mi sesión... entré mi escritorio habitual y desde aquí con un tiempo record de aproximadamente 3 horas escribo esto para que no se me olviden las premisas que ya escribí anteriormente. ;)

OK ya preveo algunos comentarios de Milton , pero creo que me gustarían muchos más al respecto.



Comentarios please!!!!

1 comentario:

Mis Mugres dijo...

Esta muy bueno tu blog, lo estare visitando seguido y leer despacio, lo saque de la lista de ubuntu, yo apenas ando empezando con ubuntu, felicidades!!!!